玩WordPress » 技巧方法 » 2008 » 11 » 09 » 让Simple tags能在WordPress 2.7中运行

让Simple tags能在WordPress 2.7中运行

Simple tags可以说是WordPress中最好的加强tag功能的插件了,但当你在WordPress 2.7中激活这个插件的时候,你会遇到一点小问题,在管理后台的顶部会出现一句“Simple Tags can’t work with this WordPress version ! You must use Simple Tagging Plugin for it to work”,然后虽然你看到插件页中,这个插件是激活了,但实际却没有运行,该添加的功能都没有添加上。
让Simple tags能在WordPress 2.7中运行

难道WordPress 2.7已经像Firefox那样能判断某一个插件能否在特定版本中正常运行?非也,这只是Simple tags自己对WordPress的版本进行判断,然后给出的警告。

解决很简单,Simple tags在google code中就已经有人给出了答案
在管理后台的插件编辑器中打开Simple tags,找到如下一句

if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false  ) 

将其修改为

if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false || strpos($wp_version, '2.7') !== false )

是的,就是这么简单,现在你又可以正常地使用Simple tags了。

5 Responses to “让Simple tags能在WordPress 2.7中运行”

  1. 小墨 says:

    原来是这么个问题~

  2. […] 如果你安装了Simple Tags,你会看到有个小黄条出现: 参考“让Simple tags能在WordPress 2.7中运行”,你可以让Simple tags再次复活; […]

  3. maomy says:

    赞,神奇:)

  4. Stephen says:

    就这样???????