解决WordPress自动升级需填写ftp信息的问题

一般WordPress自动升级和插件自动升级时遇到要填写ftp信息的问题都是由空间的权限问题引起的,这个权限包括文件夹的写权限和文件夹所有人权限。知道问题的所在,解决就很简单了。

一般虚拟主机(share hosting)因为不会涉及文件夹所有人的问题,所以仅需加大文件夹的权限即可:
chmod -R 755 /home/www/wanwp.com
chmod是修改文件(夹)权限的命令,这里加了一个R参数,就是把/home/www/wanwp.com文件夹内的所有文件(夹)的权限都修改为755(如果还未能解决,可修改为755)。

当使用VPS以上的主机时,不仅涉及文件的写权限,文件夹所有人权限也会导致需填写ftp信息的问题。
例如:使用lnmp安装的环境中,不是使用www用户进行安装WordPress操作时,就会引起这个问题。解决只需修改文件夹的所有人为www就行了:
chown -R www /home/www/wanwp.com

这里的操作都是假设你使用的主机为Linux环境,并拥有SSH权限。