5个Google统计相关的WordPress插件

Google Analytics 是最棒的网页统计之一,她强大并且免费,很难让人不爱她。 作为全球最多人使用的 blog 平台,WordPress 拥有的与之相关的插件必然不少。这里介绍的5个,就是其中的佼佼者。 原文链接: 5 Rocking Google Analytics Plugins for WordPress (adsbygoogle = window.adsbygoogle || []).push({});

more...

flinks

关于WordPress插件有很多想法,由于时间和道行的问题,暂时无法把想法变成能用的插件,记录一下以免忘记。 网站的链接通常被称之为“友情链接”,我不太清楚这个说法是从何而来,也无心考究来源。在刚开始玩网站的时候,我就被告知交换“友情链接”是入门必修课之一。时至今日,虽然现在的入门课程仍旧包含了交换“友情链接”一课,但“友情”二字的虚伪面具却也已

more...

自定义油兔逼插件

自定义油兔逼的功能很简单,在WordPress发表新文章时,只要在自定义段中填写YouTube的视频id,即可在文章中插入YouTube的视频或者截图。 Read More »

more...

WordPress自动实现摘要

WordPress在不使用任何的插件的情况下是能在首页实现摘要显示的,但她实现起来不是那么方便,或要自己做文章的中间加<!–more–>;或要修改主题中的标签。总之是不太方便吧。要怎样才能让WordPress自动实现在首页等位置(除了单篇文章的其他页面)只显示指定字节数的摘要,而不用操作其他不关文章的事呢?下面的代码可以帮你实现。 Read More »

more...

update_tweet:发布新文章后,通知twitter

早两天开始,冰古(Follow bingu 即可添加冰古了)又开始折腾twitter这个microblog始祖。虽然我们跟她只能隔墙交流,但大家都是热情不减。dabr、tweetr等工具的应用也使墙体漏洞百出。 按照WordPress和twitter的热门程度,发布新文章后,发送一条包含新文章标题、链接等信息的消息到twitter这样的一个插件是不会少的。但一来我懒得去找,二来我仅仅需要的也只是这样一个简单的功能。

more...

Ajax Plugin Helper

Ajax Plugin Helper是一款使后台插件页面中的激活、禁用、升级或删除等工作免刷新化的插件。也就是说我们在对多个插件进行操作时可免除页面的刷新,节省鼠标点击的次数。 有图有真相,没装这个插件前,我们升级一个插件需要页面刷新两次,鼠标点击两次 装上后,页面0刷新,鼠标点击一次搞定 下载Ajax Plugin Helper 这个插件要求WordPress版本至少要达到2.8。它是由Matt制作的,

more...

WordPress开发者必备插件

WordPress Console,一个WordPress开发者必备的WordPress插件。 WordPress控制台,从字面和界面上就可以看出这个插件的用途,她如同Windows的命令提示符和*NIX的控制台那样,输入命令就能返回数据。 WordPress控制台中可以输入PHP或WordPress(包括激活的插件)中可用的函数,运算符等,它运用了AJAX技术,使得能像真实的控制台般立即返回数据。 还是不清楚?看作者的视频教程。 Read More &r

more...

Some Chinese Please!

Some Chinese Please!是冰古在2007年制作的一款防御Spam留言(包括trackback和pingback)的WordPress插件。新版本发布,就转移到“玩WordPress”这里来了。 工作原理 一般blog(特别是由WordPress等外国平台构建的blog)收到的Spam基本都是纯英文或其他外文语言构成的,而我们通常的文章都是用中文写作的,纯英文留言出现的机率是极低的。这时,限制留言内容必须带有中文字就是限制Spam留言的

more...

WordPress的jquery库不起作用?

这个应该不是什么新信息,但我却是现在才搞清楚。 在我制作的多个插件中都是用到了jquery这个便利的javascript库,但让我很郁闷的是,虽然已经调用了jquery,在html代码上也有jquery的链接,但插件中应有的效果却始终不能显示出来。但是改为调用Google AJAX Libraries API或jquery上的jquery.js都能出来效果。所以插件中我只好用Google AJAX Libraries API来代替了。 这实在不是什么好主意,但当

more...

新建WordPress 2.8必用的两个hack

从WordPress的版本升级到2.0开始,WordPress开始向”肥大“发展,这就导致了新版本的WordPress中必有你不太喜欢的功能。 例如2.6开始加入的post revision特性,2.8开始加入的后台编辑器的代码高亮特性等。 如果不喜欢,我就会考虑关闭这些功能。但WordPress很多特性都不能在后台控制,唯一的方法就是写一小段代码去关闭它们。 这里将列举出如何关闭上面提到的两个不太必要的特性。

more...